Page 1 of 1

Encore, ruby ci debut issue

Posted: Tue Jan 14, 2020 10:12 pm
by pumpinainteasy
Installed a ruby ci system on latest bypass generic 3.10.whatever, new dispensers with flex pay 42.11?22. Verified debit outside activated with network, requiring BAMS 601 encryption. Gilbarco only lists 1 BAMS for RKL. Run debit card at pump, get "sale declined, pinpad error". Not running emv at the pumps yet. Dcr set for dukpt in module. Network sees the sale declined and says it's an encryption issue. Credit goes right thru. Going back tomorrow to try some changes/cold starts/purges. RKL'd UPMs twice already. Any thoughts?

Re: Encore, ruby ci debut issue

Posted: Wed Jan 15, 2020 5:04 pm
by Cyclepower
Buypass has like 6 different encryptions, it's just a matter of finding the one that works. I've had luck having the owner call their CC processing company and asking them what version of encryption you need.

Re: Encore, ruby ci debut issue

Posted: Wed Jan 15, 2020 8:01 pm
by javamelt
Debit enabled in dcr attributes? I’d also contact credit processor like mentioned above to verify exactly which encryption to use.

Re: Encore, ruby ci debut issue

Posted: Thu Jan 16, 2020 5:18 pm
by pumpinainteasy
Bypass stated to us the BAM 601 encryption is the one required. With debit enabled at dispensers, network sees the sale declined for encryption but gilbarco has only 1 tdes BAM encryption so they say. A previous site we installed running bypass and BAM, network checked their table setup and only difference they see is 2 options on encryption, a 601 and a 603. Either way, back to "gilbarco only having 1 BAM" so they say. Network emailed the acct manager, probably won't here anything for a few days. BAM 601 works in the mx at the register. Tried a fresh upm with another rkl, no change. Made some changes in CI programming and changed back just to see if it wasn't taking the changes, no difference. Sorry folks, credit only at this time!